Datacenter Server Down [REF: EDID636876]

Incident Report for EDID Design dba Corp Status Page

Resolved

Dear Clients – After our Incident that the server was down, on reference number: EDID636876, we can now let our clients know what all this has been sorted, just so that clients are aware that, we’ve changed the datacenter’s domain name, from hostname: xenon.edidesigninc.com, to new domain name: xenon.ediddesign.network.

Reason why we changed this:

We had to change our domain name, since a provider we don’t trust has decided not to give us full control of our domain name, after paying nearly: $50 bucks, to renew the domain name: edidesigninc.com. This is why we’ve had to completely change it all around.

Where is the client center, where can I access my account?

You can still login to the client area for now by going to: www. edidesigninc.com, we will soon be changing fully to edid-design.com, don’t worry about registering, we will migrate all client accounts over. This will not be initiated till 9/29 – 10/2. All web hosting is the same, changes are to follow from: 10/2.
Posted Sep 26, 2025 - 00:54 EDT

Update

We are continuing to monitor for any further issues.
Posted Sep 24, 2025 - 21:47 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 23, 2025 - 14:48 EDT

Update

FBI and E.U: Interpol are Involved. It would appear we were attacked, don't worry, all data is secure, by our Paid Secure Socket Layer (SSL Certificate.)
Posted Sep 22, 2025 - 08:40 EDT

Investigating

We're Investigating why, our Datacenter, and all clients hosting has dropped. We're Investigating the matter, with the datacenter.
Posted Sep 21, 2025 - 17:39 EDT
This incident affected: XENON.EDIDESIGNINC.COM DATACENTER (Main xenon.edidesigninc.com - Datacenter Server, CLOUDLINUX - XENON.EDIDESIGNINC.COM, DDOSS PROTECTION API, cPGuard WH Protection, DNS NAMESERVERS @ Xenon.edidesigninc.com, Email API) and Billing - Blog API Center (WEBSITE, BILLING, BLOG API).