Website & Server Side Degraded Performance

Incident Report for EDID Design dba Corp Status Page

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 00:32 EDT

Investigating

We’re currently showing a degraded performance website and server side. We’re looking into this; we may need to extend the ram of the website / server side. As were also down for maintenance too, this may influence it. This isn’t an ISP issue. We’re Investigating it now.
Posted Jun 26, 2025 - 11:55 EDT
This incident affected: XENON.EDIDESIGNINC.COM DATACENTER (Main xenon.edidesigninc.com - Datacenter Server) and Billing - Blog API Center (WEBSITE & CLIENT AREA API - www.edidesigninc.com).