Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 25, 2025 - 08:00 EDT
Scheduled
Dear Clients - We're informing all clients that on: 8/25 from 8am EDT -5. We will commence CPGuard Repairs. Please be advised websites are protected at all costs.. We will let all clients know, as we progress with this work on: 8/25.
Posted Aug 17, 2025 - 21:46 EDT
This scheduled maintenance affected: XENON.EDIDESIGNINC.COM DATACENTER (cPGuard WH Protection).