Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 26, 2025 - 05:30 EDT
Scheduled
Dear Clients - Since we changed our main company domain name, we've now got to update everything, on our status page center. It's quite excessive work to do. This maintenace will start at: 5:30am EDT. Time writing this: 11:52pm EDT.
Posted Sep 26, 2025 - 00:52 EDT
This scheduled maintenance affected: Network Status Page Center | Centro https://edidesignservicesnetwork.statuspage.io/.