The issue has been identified and a fix is being implemented.
Posted Jul 04, 2025 - 08:04 EDT
Investigating
We, have some Information that the System Automations failure, this is not a big impact to our services. Just degraded performance, we're investigating this at, this time.
Posted Jul 03, 2025 - 13:56 EDT
This incident affected: XENON.EDIDESIGNINC.COM DATACENTER (Main xenon.edidesigninc.com - Datacenter Server) and Billing - Blog API Center (WEBSITE & CLIENT AREA API - www.edidesigninc.com).