superCARS & MSFS Licensing Server Is Down Till Further Notice

Incident Report for EDID Design dba Corp Status Page

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 15:13 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 27, 2025 - 01:50 EDT

Update

We are continuing to investigate this issue.
Posted Jun 24, 2025 - 21:40 EDT

Investigating

Since our migration of new datacenters, our licensing servers are down, same goes for our MSFS Servers and Licensing servers - we will make any sort of announcements via our blog, and website, when these will be backup.
Posted Jun 24, 2025 - 21:38 EDT