We are continuing to monitor for any further issues.
Posted Jul 01, 2025 - 03:47 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2025 - 03:46 EDT
Investigating
We are currently investigating this issue.
Posted Jun 30, 2025 - 14:47 EDT
This incident affected: XENON.EDIDESIGNINC.COM DATACENTER (Main xenon.edidesigninc.com - Datacenter Server, DDOSS PROTECTION API, cPGuard WH Protection) and Billing - Blog API Center (WEBSITE & CLIENT AREA API - www.edidesigninc.com).