We are continuing to work on a fix for this issue.
Posted Aug 11, 2025 - 07:47 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 05, 2025 - 08:28 EDT
Investigating
Dear Clients - We've been notified that, some how websites are not being protected, we're now investigating this issue, this is now at status: Major Outage. We'll be back with further more updates, as we progress with our Investigation. We can confirm that DDOSS Protection and other security and firewall is working at this time.
EDID Design, Corp 6:30am EDT - 5.
Posted Aug 05, 2025 - 06:29 EDT
This incident affected: XENON.EDIDESIGNINC.COM DATACENTER (cPGuard WH Protection).